RTSP Stream from Server

Answered

Comments

4 comments

  • Avatar
    Sergey Yuldashev

    Hello Lazer,

    Forcing the resolution invokes the transcoding if you request some custom value. So the server must support transcoding and have special value SF_SupportsTranscoding among for the attribute serverFlags  in the response to api/moduleInformation request.

    In my case it does and see the result of using different URI's in the VLC:

    rtsp://10.0.1.20:7001/b56d54f3-021f-8886-5412-61abeafcd95c

     

    rtsp://10.0.1.20:7001/b56d54f3-021f-8886-5412-61abeafcd95c?resolution=240p

     

    By deafult only ARM servers are not allowed to perform transcoding. Such servers will always return errors instead of the stream.

    Let us know if it's not the case for you.

     

     

     

    0
    Comment actions Permalink
  • Avatar
    Norman Graafsma

    Hi Lazer Wiesner,

    Did you manage to resolve the issue or is further assistance required? 

    0
    Comment actions Permalink
  • Avatar
    Decoux Guilhem

    Hi,

    I can see easily how to call the main stream, and understand how to do transcoding... (but I'm using Debian RPI)

    But how can we simply call the substream using the Nx adress ? 

    rtsp://admin:MyPWDisSafe@192.168.0.21:7001/078d765a-c2d9-7cad-a176-f081c7883822

    Do we have to do do port forwarding on the router ? Port 7001 ? Port 80 ? Port 554 ?

    Waiting for your feedback !

    Cordialement

    0
    Comment actions Permalink
  • Avatar
    Sergey Yuldashev

    Hi Decoux Guilhem,

    If you want send any request and get any information from the server, you should initiate connection to the Server port. Which is by default 7001 but could be different according to your configuration.

    To understand how to call the secondary stream, please refer to the API documentation, more specifically you need a stream query parameter of the RTSP Streaming documentation:

    Open high quality stream if parameter is 0 or low quality stream if parameter is 1. 
    By default server auto detect preferred stream index based on destination resolution.

    So in your case it would look like:

    rtsp://192.168.0.21:7001/078d765a-c2d9-7cad-a176-f081c7883822?stream=1

    One more advise - please avoid using credentials as a part of your urls.
    Some clients(e.g. VLC) will parse and then encrypt them, other ones will send them as a plain text over the network. I believe, it's not the best thing to do.

    0
    Comment actions Permalink

Please sign in to leave a comment.