Axis camera Analytics event trigger still not working

In Progress

Comments

16 comments

  • Avatar
    Norman Graafsma

    Hi Max G,

    Is it possible to make the camera accessible via port forwarding with such events configured, so we can add it to our test environment and investigate the issue? 

    If so, I'll convert the topic into a support ticket, so you share the login credentials privately.

    0
    Comment actions Permalink
  • Avatar
    Max G

    Hi Norman Graafsma!

    Unfortunately no, but I am fully at your service when it comes to testing.
    Please convert it into a support ticket, and let's test it together.

    0
    Comment actions Permalink
  • Avatar
    Norman Graafsma

    Hi Max G,

    Unfortunately, that isn't possible.

    In order to investigate such issues, we need to add the devices to our test environment, so we have a controlled system and are able to use proprietary applications if required.

    For now, I would recommend to set up a system, could be a virtual machine, with solely the latest release installed and try to reproduce the issue in that system.

    0
    Comment actions Permalink
  • Avatar
    Max G

    Norman Graafsma,

    Do you mean that update from the previous version (I am using Ubuntu distributive of NX) could lead to traces of former bugs?
    I mean those that were described here:

    https://support.networkoptix.com/hc/en-us/articles/1500006814301-Instant-Analytic-Events-are-Triggered-only-Once-on-the-Build-4-2-0-326xx-

    0
    Comment actions Permalink
  • Avatar
    Norman Graafsma

    Hi Max G

    That's not what I implied, and I understood the issue you encounter.
    What I try to suggest is to use a clean environment so that any side effects that might occur for whatever reason are eliminated as much as possible.

    0
    Comment actions Permalink
  • Avatar
    Max G

    Nothing changes after testing on fresh system.
    In case of work with D2050VE radar, and events recording runs all the time with small breaking ups when Radar does not detect movement.

    With cameras (P1368E, M2026LE-MKII, and Q6125LE) while using MotionGuard the rule is almost the same, but the record lasts only once when it should work continuously until Analytics event on camera stops.

    Did you make any actual tests with Axis cameras?

    Is there a general recording buffer setting for the camera(I previously used Xprotect that had this option for every camera)?

    0
    Comment actions Permalink
  • Avatar
    Norman Graafsma

    Hi Max G,

    I ran my test with the Axis P1435LE, but I'll request access to some other cameras, preferably the ones you mentioned, and get back at you after I have tested with these.

    0
    Comment actions Permalink
  • Avatar
    Max G

    Hi Norman Graafsma!

    I hope your tests are running fine & we will be able to solve the issue with Analytics.

    In the meanwhile I am trying to launch Generic Event thru NX API. Would you please try if it works on your camera(s)?

    Here's what I try to run when my MotionGuard on Axis camera starts motion:
    http://192.168.0.3:7001/api/createEvent?source=front&state=Active
    And corresponding Inactivation command when it finishes:
    http://192.168.0.3:7001/api/createEvent?source=front&state=Inactive

    When this Generic Event is executed from Axis camera I receive Generic Event notice in NX, but in fact recroding doesn't start. Maybe there's some special way of such commands format needs to be run for Axis camera? Surely, Analytics operability would be ideal, as it implies Pre/Post-buffer, but in temporarily I'm looking for alternative ways of utilizing Axis analytics with NX.

    Looking forward for your further assistance.

    0
    Comment actions Permalink
  • Avatar
    Norman Graafsma

    Hi Max G,

    There seems to be an issue with the virtual loan of Axis, so I do not have access to the devices yet.

    For the generic event to enable/disable recording, please check out THIS support article.

    0
    Comment actions Permalink
  • Avatar
    Norman Graafsma

    Hi Max G,

    I was able to request the cameras, but the radar was not available.

    As soon as the cameras are available, I'll request VMD acap and hopefully get them in time.

     

    0
    Comment actions Permalink
  • Avatar
    Max G

    Hi Norman Graafsma!

    Radar events are working, but VMD/MotionGuard ACAP apps events - not.
    I guess if you test with above apps, that will be indicative enough.
    Waiting... Thanks!

    0
    Comment actions Permalink
  • Avatar
    Norman Graafsma

    Hi Max G,

    Camera P1368E, M2026LE-MKII are set up with Motion Guard and are waiting for motion to detect. 
    The Q6125LE, unfortunately, wasn't available.

    My P1435LE still delivers the events without any flaws: 

    0
    Comment actions Permalink
  • Avatar
    Max G

    Norman Graafsma

    It would be interesting to know P1368E, M2026LE-MKII behaviour with NX / MotionGuard. 
    Please show your configuration of Pre/Post-Buffer too.
    Thanks!

    0
    Comment actions Permalink
  • Avatar
    Norman Graafsma

    Hi Max G,

    This is my config; just as default as possible:

    Unfortunately, I wasn't able to reproduce the issue with the virtual loan cameras. For some reason no events were sent over the network, just the video stream. Probably a limitation of these virtual loan cameras.

    So, in order to resolve the issue, we need uncompromised access to cameras that have the issue and if you are not able to provide remote access, there is nothing we can investigate at this moment, and we will have to wait until the issue occurs somewhere else, and they can provide us remote access for further investigation.

    0
    Comment actions Permalink
  • Avatar
    Max G

    Hi Norman Graafsma!

    Please let me know if we can discuss it in private.

    0
    Comment actions Permalink
  • Avatar
    Norman Graafsma

    Hi Max G,

    I'll convert this topic into a ticket, so you can share anything privately.

    JIRA-VMS-23387

    0
    Comment actions Permalink

Please sign in to leave a comment.