Android 13 Notifications not working

Completed

Comments

11 comments

  • Avatar
    Norman - Nx Support

    Hi Jaimi,

    Please check the version of the Nx Mobile application.
    Android 13 is supported from v22.5.36150 onwards and might have issues in previous versions.

     

    0
    Comment actions Permalink
  • Avatar
    Jaimi Taylor

    Hi Norman,
    That is the version that the phone is running.
    Any further suggestions that you may be able to suggest?

    0
    Comment actions Permalink
  • Avatar
    Norman - Nx Support

    Hi Jaimi Taylor,

    Please check THIS community topic where the same issue has been reported.
    Can you also enable VERBOSE (DEBUG2) logs, reproduce the issue, and share the log ID?
    Once done, you can revert the loglevel to NONE.

    0
    Comment actions Permalink
  • Avatar
    Jaimi Taylor

    Hi Norman,

    Please see the logs..
    9054cf06-2bf4-4667-bb62-b9f08103e5a0

    I enabled the logging, triggered an event that went through to another phone. This phone did not receive it.

    Please let me know if you need anything further.

    Many thanks.

    0
    Comment actions Permalink
  • Avatar
    Norman - Nx Support

    Hi Jaimi Taylor,

    That was quick! Thanks. Really appreciated.
    I have shared the log ID with our team and I hope to provide an update, or even better, a fix, as soon as possible.

    0
    Comment actions Permalink
  • Avatar
    Norman - Nx Support

    Hi Jaimi Taylor,

    So far, our developers couldn't find anything in the logs that were created.

    Could you try some things:

    1. Go to system “App info” and try to turn off option “Remove permissions if app is unused”, then try to turn off/on notifications in the mobile client app and check if it helps

    2. If not, please try clean data and cache in the app system settings

    Please let us know the results.

    If this doesn't solve it, we need ADB logs from the phone directly as described here: LINK

    For the right instructions, please scroll down to the section:

    Collect the Nx Mobile Debug Log with Device System Log

     

     

    0
    Comment actions Permalink
  • Avatar
    Norman - Nx Support

    Hi Jaimi Taylor,

    I hope this message finds you well. I am following up on the issue you reported previously to see if it is still relevant. We want to make sure that we provide the best possible support and assistance to our valued customers, and I would appreciate it if you could confirm whether the issue you experienced is still ongoing.

    If you are still experiencing the issue, please let me know and provide the information as requested above so that we can work towards finding a resolution as soon as possible. If the issue has been resolved, please do not hesitate to let me know as well.

    Thank you for your time and cooperation. I look forward to hearing back from you soon.

    0
    Comment actions Permalink
  • Avatar
    Jaimi Taylor

    Hi Norman,

    Yes, still experiencing the issue.
    Just haven't had the chance to go through the quite complex log gathering process.
    Hopefully it won't be too much longer.

    0
    Comment actions Permalink
  • Avatar
    Norman - Nx Support

    Hi Jaimi Taylor,

    Another customer reported the same issue, but just reported the issue was resolved after a software update.
    Could you check if the are updates are available for your phone, and after the update the issue was resolved?

    0
    Comment actions Permalink
  • Avatar
    Jaimi Taylor

    Thanks for getting back to me.
    I was actually able to resolve the issue yesterday by clearing the cache and app data within the phone.
    I guess is that the appdata was corrupt in some way when the transfer to the new phone occurred.

     

    Many thanks for all of your help on this.

    0
    Comment actions Permalink
  • Avatar
    Norman - Nx Support

    Thank you for the update Jaimi Taylor.
    I'm delighted to read it has been resolved.

    0
    Comment actions Permalink

Please sign in to leave a comment.