MetaVMS R8 version installing stub

Comments

7 comments

  • Avatar
    lechee lai

    after check it's not enable in default stub_analytics_plugin_ini.h

    NX_INI_FLAG(0, throwPluginEventsFromDeviceAgent, 1 "Periodically throw plugin events from DeviceAgent to Server.");

    ->

    NX_INI_FLAG(1, throwPluginEventsFromDeviceAgent, 1 "Periodically throw plugin events from DeviceAgent to Server.");

    but after that it's another issue

     

    0
    Comment actions Permalink
  • Avatar
    Nx Support

    Hi Lechee,

    I'll try to answer your questions:

    The difference between plugins and plugins_optional folders is the following - the plugins from the plugins folder are loaded by the server upon startup in case if you do not disable them explicitly (you can do that via plugins.ini). The plugins from plugins_optional folder are NOT loaded by the server upon startup in case if you do not explicitly enable them via plugins.ini.

    Recently we have changed the default values for throwPluginEventsFromEngine and throwPluginEventsFromDeviceAgent stub_plugin settings from 1 to 0 - now the plugins do not throw Plugin Events by default. But you can always enable it via stub_analytics_plugin.ini, no need to recompile the plugin, you can simply change the settings using the stub_analytics_plugin.ini file.

    I do not see any issue on your last screenshot, though. Seems to work fine - you had enabled throwPluginEventsFromDeviceAgent setting and on the screenshot we can see the notifications about such events. Could you please clarify what the problem is?

    0
    Comment actions Permalink
  • Avatar
    lechee lai

    Thanks Nx team,

      is the (red) Error message from Engine "Error message description" is correct? usually it should have bounding box on video? in linux name convention still plugins.ini where is this config file location 

     

     

    0
    Comment actions Permalink
  • Avatar
    lechee lai

    ok got the point yout stub only show 3 different message (info, warning and error)

    0
    Comment actions Permalink
  • Avatar
    Nx Support

    Hi Lechee,

    Glad you sorted it out!

    As for the error message, it shouldn't have a bounding box on the image. It is an event, not an object. Those events are needed primarily for plugin health diagnostics, not for video analytics.

     

    If you are looking for objects (bounding boxes) - open Objects tab in the right panel. Once you open it - you should see incoming bounding boxes

    0
    Comment actions Permalink
  • Avatar
    lechee lai

    ~/.config/nx_ini/plugins.ini always show zero byte after change the setting and restart the NX server

    0
    Comment actions Permalink
  • Avatar
    Nx Support

    If you are running the server as a service that's a correct behavior. It will work with ini files located in the folder in discussion only if you are starting the server manually from the console.

    If you want to use ini files with server running as a service, you need to create /etc/nx_ini/ folder and put your ini files there. Make sure that the server has rw access to /etc/nx_ini/ folder and its contents (you can simply run chmod -R 777 /etc/nx_ini/).

    0
    Comment actions Permalink

Please sign in to leave a comment.