Negative Presentation Timestamp of RTSP

Comments

7 comments

  • Avatar
    Maxim Podstrechny

    Dear Paul,

    Thanks a lot for your report, it seems to be an issue worth investigating on our side. We are already working on it, I will come back to you as soon as we have any news.

    Thank you again, hopefully we will have some news for you soon.

  • Avatar
    Tony Luce

    Hey Maxim - any updates here?

  • Avatar
    Maxim Podstrechny

    Hi Tony, Paul,

    Sorry for late reply, we had a holiday season here. I just checked the status of the task, it is still in progress, no news so far, sorry.

    I will try to push it a bit.

  • Avatar
    Leonid Busygin

    Hi Pual,

    Is issue still reproducible?

  • Avatar
    Paul Kim

    The server still has the problem.
    You can see the negative pts when you connect to the site below.

    server: v3.2.0.28341

    rtsp://demo:demo@100.32.247.140:7001/{bc5a13a1-5823-711a-c675-7176604eee7e}?stream=0&pos=1551120562000

  • Avatar
    Leonid Busygin

    What tool do you use? The issue in first frames only or many times in random places?

    ffprobe print such result: 

    ffprobe  -show_frames -show_entries frame=pkt_dts_time  "rtsp://demo:demo@100.32.247.140:7001/{bc5a13a1-5823-711a-c675-7176604eee7e}?stream=0&pos=1551120562000"
    ffprobe version n3.1.9 Copyright (c) 2007-2017 the FFmpeg developers
     built with gcc 5.4.0 (Ubuntu 5.4.0-6ubuntu1~16.04.10) 20160609
     libavutil      55. 28.100 / 55. 78.100
     libavcodec     57. 48.101 / 57.107.100
     libavformat    57. 41.100 / 57. 83.100
     libavdevice    57.  0.101 / 57. 10.100
     libavfilter     6. 47.100 /  6.107.100
     libswscale      4.  1.100 /  4.  8.100
     libswresample   2.  1.100 /  2.  9.100
     libpostproc    54.  0.100 / 54.  7.100
    [rtsp @ 0x17a61e0] CSeq 1 expected, 0 received.
    Input #0, rtsp, from 'rtsp://demo:demo@100.32.247.140:7001/{bc5a13a1-5823-711a-c675-7176604eee7e}?stream=0&pos=1551120562000':                                                                                                                                                                                                
     Metadata:
       title           : DWC-MB44iALPR - Parking Lot LPR
     Duration: N/A, start: 0.438144, bitrate: N/A
       Stream #0:0: Video: h264 (High), yuvj420p(pc, bt709, progressive), 2560x1440 [SAR 1:1 DAR 16:9], 7 fps, 30 tbr, 90k tbn, 14 tbc
    [FRAME]
    pkt_dts_time=0.438144
    [/FRAME]
    [FRAME]
    pkt_dts_time=-0.258000
    [/FRAME]
    [FRAME]
    pkt_dts_time=-0.119000
    [/FRAME]
    [FRAME]
    pkt_dts_time=0.015000
    [/FRAME]
    [FRAME]
    pkt_dts_time=0.149000
    [/FRAME]
    [FRAME]
    pkt_dts_time=0.315000
    [/FRAME]
    [FRAME]
    pkt_dts_time=0.449000
    [/FRAME]
    [FRAME]
    pkt_dts_time=0.581000
    [/FRAME]
    [FRAME]
    pkt_dts_time=0.715000
    [/FRAME]
    [FRAME]
    pkt_dts_time=0.881000
    [/FRAME]
    [FRAME]
    pkt_dts_time=1.015000
    [/FRAME]
    [FRAME]
    pkt_dts_time=1.150000
    [/FRAME]
    [FRAME]
    pkt_dts_time=1.317000
    [/FRAME]
    [FRAME]
    pkt_dts_time=1.448000
    [/FRAME]
    [FRAME]
    pkt_dts_time=1.582000
    [/FRAME]
    [FRAME]
    pkt_dts_time=1.716000


  • Avatar
    Paul Kim

    I am not using tools.
    Connect to rtsp with avformat_open_input of ffmpeg and make AVPacket with av_read_frame. The pts value of AVPacket was positive, but it is negative from the moment.

Please sign in to leave a comment.