Nx 5.0 Auto-discovery not working properly with certain cameras

In Progress

Comments

16 comments

  • Avatar
    Wendy Chuang

    Hi Daiki Kato,

    Could you help to collect the Wireshark packet and server debug log for us?
    Typically, the procedure will be:
    1. Remove the camera from your system.
    2. Start packet capturing.
    3. Wait for the device auto-discovered by the server then type the correct credentials.
    4. When the UNAUTHORIZED message appears, stop the packet recording and save the file.
    5. Share the server debug log and Wireshark packet with us. 

    Thank you for your cooperation.

     

    0
    Comment actions Permalink
  • Avatar
    Daiki Kato

    Hi Wendy Chuang

    I got the log. How can I give it to you?

    0
    Comment actions Permalink
  • Avatar
    Norman - Nx Support

    Hi Daiki Kato,

    You can share a download link to Dropbox, GoogleDrive, Microsoft OneDrive, uDrop, WeTransfer, etc. and Wendy Chuang can download the Wireshark pcapng file and the server debug logs for further investigation.

     

    0
    Comment actions Permalink
  • 0
    Comment actions Permalink
  • Avatar
    Wendy Chuang

    Hi Daiki Kato,

    Thanks for your sharing. 
    May I confirm if are you testing with the ONVIF device manager, or Nx client while collecting this Wireshark packet? Since the timestamp of the Wireshark packet does not match the log file.

    Thank you.

    0
    Comment actions Permalink
  • Avatar
    Daiki Kato

    Hi Wendy Chuang

    The camera is connected to br0 and the PC is connected to eth0. The Wireshark log is the br0 log. Did you want the eth0 side logs?

    0
    Comment actions Permalink
  • Avatar
    Wendy Chuang

    Hi Daiki Kato,

    My question is not related to the network interface but to the test scenario.
    While you collecting the log, are you checking the UNAUTHORIZED problem under ONVIF device manager, or under the Nx client? 

    Thank you.

    0
    Comment actions Permalink
  • Avatar
    Daiki Kato

    Hi Wendy Chuang

    I got the log following the steps you gave me.
    After seeing the UNAUTHORIZED message on the Nx client, I stopped recording packets and saved the file.
    I am not using ONVIF device manager.

    0
    Comment actions Permalink
  • Avatar
    Wendy Chuang

    Hi Daiki Kato,

    I just checked on the Wireshark packet and server log, but it looks good without any problem.
    Is it possible to share the unattended remote connection of your server computer? If you agree with this way, I'll create a ticket for you to share the private info.

    Thank you for your cooperation.

    0
    Comment actions Permalink
  • Avatar
    Daiki Kato

    Hi Wendy Chuang,

    Yes, please create a ticket.

    0
    Comment actions Permalink
  • Avatar
    Wendy Chuang

    Hi Daiki Kato,

    The ticket has been created for you. Please check your mailbox and reply to the mail directly.
    Thank you for your cooperation.

    0
    Comment actions Permalink
  • Avatar
    Daiki Kato

    Hi Wendy Chuang,

    I found similar issues with other cameras.
    This camera does not display the screen even if it is registered manually. It works fine with Nx 4.2.

    I got the log. Please download from below.
    https://drive.google.com/file/d/18J7lad9cMGmKcERPJ9YsX8PA93iL428G/view?usp=sharing 

    0
    Comment actions Permalink
  • Avatar
    Wendy Chuang

    Hi Daiki Kato,

    Please follow the steps as described below:

    1. (Remove the device from the system).
    2. Stop the mediaserver application and paste the resource_data.json file in the attachment at the following location:
      For Windows: C:\Program Files\Network Optix\Nx Witness\MediaServer
      For Linux: /opt/networkoptix/mediaserver/bin/
    3. Now start the mediaserver application again.
    4. (Add the device again).

     

    To stop and start the media server, please do it as follows:
    - For Windows: Open the task manager, select tab ‘Services’ find the mediaserver application, right-click and select; Stop or Start
    - For Linux: Open the terminal (Ctrl+Alt+T) and enter the following command; sudo service networkoptix-mediaserver stop or sudo service networkoptix-mediaserver start.

    After this, the request should be fulfilled.
    Please confirm, and we will add it to a future patch.

    Thanks!

    0
    Comment actions Permalink
  • Avatar
    Daiki Kato

    Hi Wendy Chuang,

    Thank you for your reply. I got it working with the steps above.

    0
    Comment actions Permalink
  • Avatar
    Daiki Kato

    Hi Wendy Chuang,

    With this change, only i-PRO's WV-S1135V is compatible, right?
    If the same problem occurs with other i-PRO cameras, should I add the camera name here?

            {
                "comment1": "Some cameras declare QOP in digest authentication but actually don't support it. VLC ignore this parameter and always uses more simple digest authentication.",
                "keys": [
                    "Panasonic|*",
                    "*|Panasonic*",
                    "WV-S1135V|*"
                ],
                "ignoreQopInDigestAuth": true
            },

    Of course, if I find a camera that doesn't connect, I'll report it here.

    0
    Comment actions Permalink
  • Avatar
    Wendy Chuang

    Hi Daiki Kato,

    I added this model( i-PRO's WV-S1135V) into the previous config that I shared with you via the ticket. Actually, it is applicable for devices that match the "vendor|model" pair.

    Since the config is a temporary workaround, it would be better to report the issue here if you find the new one. My colleague is also checking with the manufacturer about the device's identifier and authentication problem. Hope we could get the improvement from the device's end.

    Thank you for your report. Have a nice weekend!

    0
    Comment actions Permalink

Please sign in to leave a comment.