Error in step 3 help!

In Progress

Comments

3 comments

  • Avatar
    Andrey Terentyev

    Hello Steve Techs,

    Most probably you don't have libopenjp2 installed in your OS.

    Please, provide OS, cmake, canon, g++ versions as well as step by step description of what you are doing with commands utilized.

    0
    Comment actions Permalink
  • Avatar
    Steve Techs

    libopenjp2 installed sir.

    OS:

    Distributor ID:    Ubuntu
    Description:    Ubuntu 22.04.1 LTS
    Release:    22.04
    Codename:    jammy

    cmake: 

    cmake version 3.22.1

    g++:

    gcc version 11.2.0 (Ubuntu 11.2.0-19ubuntu1)
    Conan version 1.51.3
     
     
     
    0
    Comment actions Permalink
  • Avatar
    Andrey Terentyev

    Hi,

    Thank you for your response.

    Just FYI, we have not tested the plugin compilation with gcc/g++ version 11.2.0.

    as well as step by step description of what you are doing with commands utilized.

    Could you please provide this info? What are you doing to build the plugin?

    Please, share the output of your compilation process.

    libopenjp2 installed sir.

    Judging by this,

    ERROR: libopenjp2 >= 2.1.0 not found using pkg-config

    something is trying to find the lib with pkg-config and fails.

    Please, share the output of the following commands:

    sudo apt list --installed | grep libopenjp2sudo pkg-config --list-all | grep libopenjp2

     

    0
    Comment actions Permalink

Please sign in to leave a comment.