Can't add Axis P3727-PLE cameras

In Progress

Comments

15 comments

  • Avatar
    Wendy Chuang

    Hi Taylor Griffin,

    We have solved the AXIS camera's problem and merged the fix to the next patch, which is scheduled to release this month. Currently, we could offer the custom build for internal testing only. It is not recommended to deploy it on the production server since it has not finished all the verifications. Do you want to give it a try first?

    Thank you.

    0
    Comment actions Permalink
  • Avatar
    Matt Barber

    I'm seeing this issue on this model camera as well in many locations.

    running 4.2 server   was working fine until I changed settings, now dropping/offline.

    Is there a build available to test out yet?

    0
    Comment actions Permalink
  • Avatar
    Matt Barber

    Ahhh.. I think I got help form DW tech on this... one of the few who knew how to handle it.

     

    ONVIF profile not working so nicely with the Axis P3727-PLE

    Actually no profiles were even showing up in the axis camera web interface I was using.

    1. turn off autodiscovery and probably optimization in VMS

    2. Delete cam from VMS

    3. Soft reset camera---re log in.. re-create any ONVIF credentials and set master password etc.

    4.  Create an onvif profile that matched what the VMS is looking for.. I think dwspectrumP  no spaces.. uppercase P.

    5.  Re-add camera and handshake should work now.

    6. Set recording schedule etc..

    7.  re-enable optmization and push recording configs to cam.. 

    Now it's working.. or should I say.. I can now support the 100 plus cameras like this with the VMS solution I sold them.. that has been a problem for months and months.  Not sure who to point the finger at, but an easy fix would be nice.

     

     

     

     

    0
    Comment actions Permalink
  • Avatar
    Ichiro

    Hi Matt Barber,

    This issue has been fixed on latest patch/release of Nx Witness 5.0.0 and DW Spectrum.
    There is no need to use the ONVIF to interact with AXIS, the integration is completely done in proprietary API.

    Here is a version for your use: 
    Build No. : 35746 
    Password : t531vl

    0
    Comment actions Permalink
  • Avatar
    Ichiro

    Hi Taylor Griffin,

    For Nx Witness, please use the following version:

    In-Client Upgrade:

    Build Number:   35745
    Password:   x7fivl
    0
    Comment actions Permalink
  • Avatar
    Matt Barber

    Excellent!  Thank you for the follow up and update.

     

    Can you verify that future full release of 5.0 update will include this patch?  Or is this still custom build going to be needed to better work with the Axis cameras issues?

    If there is a release that will contain this fix, please advise.  

     

    I will test with customer who has many of these axis models in place on DW.

    0
    Comment actions Permalink
  • Avatar
    Ichiro

    Hi Matt Barber,

    This would be included in the 5.0 release hot fix, 5.0 patch and after. Here is the version for 5.0 release hot fix  for your use: 
    Build No. : 35746 
    Password : t531vl

    0
    Comment actions Permalink
  • Avatar
    Matt Barber

    Thanks for the details.

    Update...   Have a site with 4 of these  AXISP3727PLE cams.

     

    I updated the DW software to 35746

    I can add the cams, but it is requiring 16 licenses to make it work.  There are 4 licenses on the system to handle the 4 multi imager cameras.

    I updated FW on one camera to test, but bottom line DW will not find the camera with the ONVIF profile created for this purpose.

    I also tried re-creating the profile as before, but it did not resolve the issue.

    0
    Comment actions Permalink
  • Avatar
    Matt Barber
    0
    Comment actions Permalink
  • Avatar
    Norman - Nx Support

    Hi Matt Barber,

    I have just created a fix for that.

    You'll see in the image below now 2 licenses are used, one for the Axis P3727 device and one for the other camera in my system.

    Please do the following:

    Please follow the steps as described below:

    1 - Remove the device from the system.
    2 - Stop the mediaserver application and paste the resource_data.json file in the LINK at the following location:
        For Windows: C:\Program Files\Network Optix\Nx Witness\MediaServer
        For Linux: /opt/networkoptix/mediaserver/bin/
    3 - Now start the mediaserver application again.
    4 - Add the device again.

    To stop and start the media server, please do it as follows:

    For Windows: Open the task manager, select tab ‘Services’ find the mediaserver application, right-click and select; Stop or Start
    For Linux: Open the terminal (Ctrl+Alt+T) and enter the following command; sudo service networkoptix-mediaserver stop or sudo service networkoptix-mediaserver start.

    After this, the request should be fulfilled.
    Please confirm, and we will add it to a future patch.

    0
    Comment actions Permalink
  • Avatar
    Matt Barber

    Sweet!   Thank you for the efforts.   I will have some time today to try to resolve the issue and get some feedback for you.

     

    I certainly appreciate your fast reply and help.

     

    0
    Comment actions Permalink
  • Avatar
    Matt Barber

    Ok..

    In DW I assume the file should be placed in 

    C:\Program Files\Digital Watchdog\DW Spectrum\MediaServer

    Stoped server, dropped file, started server, turned on autodetect.

    Each camera was discovered 2x in the tree.    DW would not communicate to the camera using ONVIF account/credentials.  Only as Root account fyi.

    I applied the root credentials to all instances of the camera in the tree.. and 1/2 of them bloomed into quad channel cams.   I created recording schedule and copied to other cams.. it only required 4 licenses.  YAY!

    So this works, but not as pretty as I would like customer experience to be.   I know this may be an issue with Axis and how they do some of their thing, but this issue has burned time.

    I would also like the default option to show the 4 main camera streams from the camera, and the quad view feed from stream 5 on these cameras.  It's just a nice view and layout.   This happens sometimes by defaulit, but the licensing and other settings we addressed here became issues.

    0
    Comment actions Permalink
  • Avatar
    Norman - Nx Support

    Hi Matt Barber,

    You guessed the right location.

    But, then there are some differences what makes it time-consuming and not quite right.

    Axis cameras do not need Onvif. Perhaps this caused that the device was recognised as an encoder, not as a multi-sensor device. (Check the different icons on your and my screenshot). Maybe it also caused the duplicates.

    So, I would disable Onvif (there is no need) and allow the system to discover the devices.
    This way they should appear as multi-sensor devices within seconds and added correctly within seconds.

    We do not support anything else than the current situation. You could add the 5th stream as an RTSP stream of course, for live recording this isn't an issue, for recording it would require an additional licence.

    If issue keep occurring, I'm more than happy to spend some time on the system myself to check if I can resolve it, since it should be a painless process.

     

     

    0
    Comment actions Permalink
  • Avatar
    Matt Barber

    Ok.. I will have to sort out turning ONVIF off on the Axis line and test with customer on more deployments.

    Thanks for the quick help and fix on the issue.

    0
    Comment actions Permalink
  • Avatar
    Norman - Nx Support

    No problem Matt Barber.
    I'll submit the fix to our developer to be added to the next 5.0 patch.

    JIRA-VMS-36478

    0
    Comment actions Permalink

Please sign in to leave a comment.