NX Cloud "Unreachable"

In Progress



  • Avatar
    Norman - Nx Support

    Hi Anders Knutsen,

    Thank you for reporting this issue.

    Could it be that you have a Firewall in use between the client and the internet?

    • Can you check the validity of the certificate for the system?
      You can check the certificate by clicking on the certificate in the Server Settings menu, tab General.
    • Can you check which certificate is used for the cloud connection?

    For Chrome:

    1. Open the Chrome browser
    2. Open the Developer Tools with Ctrl+Shit+I
    3. Select the Security tab
    4. Navigate to nxvms.com
    5. Select View Certificate
    6. A window opens, please select the Details tab
    7. Select Export... and save the certificate
    8. Share the certificate with us.

    For Firefox:

    1. Open the Firefox browser
    2. Navigate to nxvms.com
    3. Click on the padlock in the search bar.
    4. Click on Connection Secure...
    5. Click on More information...
    6. Click on View Certificate
    7. Share the output, either as screenshots or print it as PDF and share them. 
    Comment actions Permalink
  • Avatar
    Anders Knutsen


    The firewall is a 4G router, minimal rules. Also tried enabling DMZ for the servers IP but it still doesn't work.

    The info you requested can be found here:



    Comment actions Permalink
  • Avatar
    Chris White

    I am seeing a similar issue with the DW Spectrum version as well. The version I am running is I am able to connect fine either locally or through a static IP. The second I turn off my port forwarding rules, I am unable to connect with DW Cloud. This wasn't the case in previous versions. I never had to configure any port forwarding rules for cloud services to work. https://drive.google.com/file/d/1th2MRbMaS49JKQWauCMsYdwLha5Gpmd3/view?usp=sharing 

    Comment actions Permalink
  • Avatar
    Damien Roussos

    We just updated our systems to the new We have three sites that were all on 4.2 with nx cloud working fine and visibility on the Nx app on both android and ios. 

    When upgrading the systems we have done 2. one was an inplace update. the other was a clean install. BOTH are not connecting to the nxcloud correctly. They are showing for cloud users as unreachable. The one still on 4.2 is reachable and can get into it fine on desktop and both apps. Nothing has changed with our firewall or settings and this issue is isolated to the new update both fresh install and upgrade install. 


    When I go online to the https://nxvms.com/  the servers that have been upgraded I can't view the live, see camera settings or server settings - it tells me this page cannot be loaded. When I go to view information about the server is get a 505 page error. The one on 4.2 is working fine though the same portal. 


    When I view the local web portal https://localhost:7001/#/settings everything looks good on all three servers.


    I have even disconnected and reconnected the server that was upgraded to the nxcloud and still same issues. the server that was rebuilt form scratch was added as a new server to the nxcloud with the same issues as the upgraded one. 4.2 server still working  correct with no issues. 



    Comment actions Permalink
  • Avatar
    paul chandler

    Having similar issue on 1 of 5 4G merged servers. I did discover an expired SSL cert orphaned from the in-client upgrade to 5.0. I had cert.pem (expired) and default.pem in the SSL folder.. deleted the cert.pem and that fixed most problems.. But still have one server that just wont cloud work. Today I am going to do a fresh install of Ubuntu and hope that does it.

    Comment actions Permalink
  • Avatar
    Andrew Sharrem

    I have experienced this recently only on Windows Servers.
    Servers complete the "connect system to cloud" process, but remain unreachable.
    In each instance the Primary DNS was a local DNS server (router or domain controller etc)

    Simply changing the primary DNS to bought the servers online.
    Please share if this resolves your issue.

    Comment actions Permalink

Please sign in to leave a comment.