High CPU load on network optixs server (mediaserver-bin)

Comments

6 comments

  • Avatar
    David Karlsson

    I have gone thru every single setting I can find thru the network optix client, and what strikes me is that I see that "Motion detetion" is enabled under camera settings. However no motion areas are configured. Could that still mean that there are fetching of the videostream from the camera to facilitate the motion detection?

    Are there any way to turn off everything about motion detection for a server. Because we dont configure it to be on when programatically adding the camera, there are some kind of default that kicks in.

  • Avatar
    Nx Support

    Hi David,

     

    Can you please try to disable motion for an experiment and see if you have high CPU usage again?

     

    Motion detection works together with recording schedule and event rules.

    Basically, if there is a rule for motion detected event or recording is set to motion only - server needs to know when motion happens, so server pulls the stream all the time and performs motion detection. 

     

    That could be a possible reason for CPU usage, so to check that - just disable motion on all cameras and see how it goes.

    Let us know the results, please. 

     

    Additional question: do you have a secondary stream set up for those cameras? What is the resolution of primary and secondary streams?

  • Avatar
    David Karlsson

    Hi, thanks for a swift reply.

    Recording are not at all, activated as the server has not yet applied a license key (we probably should do that - ?)

    There are a lot of Event Rules for each camera that is triggered by external source (our own server backend) for doing custom HTTP commands. I hope these are not related to data transfer. 

    However I also see that there are three "On Camera Disconnected" rules. Could these in combination with the camera type of HTTP_URL_PLUGIN be making video fetching to understand if the camera are alive?

    I've disabled the rules (but didnt remove them) and disabled all motion detection.

    The cameras doesnt have any secondary stream and the primary have something low like 640x480.

  • Avatar
    Nx Support

    Once you disabled those rules and motion detection - do you see CPU spikes again?

  • Avatar
    David Karlsson

    Well the "spikes" are more of "constant step up to 100% and staying there".

    But they also have happend kind of randomly but only on days with activity but not directly related to a anything specific in time (if I try to see paterns it might be 5-20 min after last access of a camera stream). Giving it just a few hours it would not statistically have happend yet so will not know for sure before thursday/friday.

  • Avatar
    Nx Support

    What specific version are you using?

    Do you have any client applications connected to the server when you see the CPU issue?

Please sign in to leave a comment.