4.3 R1 fails to install on Ubuntu Focal 20.04 LTS docker environment

In Progress

Comments

4 comments

  • Avatar
    Tagir Gadelshin

    Hi, Pieter Viljoen
    We'll take a look at it and get back to you as soon as we have some info 

    0
    Comment actions Permalink
  • Avatar
    Tagir Gadelshin

    Pieter Viljoen
    we are still investigating this issue, but in the meantime, we released 4.3 R2. 
    If you can check if this issue is reproduced with R2 -- it will help us a lot.

    0
    Comment actions Permalink
  • Avatar
    Pieter Viljoen

    No, it still fails.

    The error is caused by `sysctl: setting key "kernel.core_pattern": Read-only file system`.

    Preparing to unpack ./vms_server.deb ...
    D020000: trigproc_activate_packageprocessing pkg=networkoptix-metavms-mediaserver:amd64

    mediaserver-eula license could not be presented
    try 'dpkg-reconfigure debconf' to select a frontend other than noninteractive

    D020000: post_script_tasks - ensure_diversions
    D020000: post_script_tasks - trig_incorporate
    Unpacking networkoptix-metavms-mediaserver (4.3.0) ...
    D002000: infodb foreach file this pkg
    Setting up networkoptix-metavms-mediaserver (4.3.0) ...
    D020000: trigproc_activate_packageprocessing pkg=networkoptix-metavms-mediaserver:amd64
    Detected runtime type: docker.
    System has not been booted with systemd as init system (PID 1). Can't operate.
    Failed to connect to bus: Host is down
    System has not been booted with systemd as init system (PID 1). Can't operate.
    Failed to connect to bus: Host is down
    sysctl: setting key "kernel.core_pattern": Read-only file system
    dpkg: error processing package networkoptix-metavms-mediaserver (--install):
    installed networkoptix-metavms-mediaserver package post-installation script subprocess returned error exit status 255
    D020000: post_script_tasks - ensure_diversions
    D020000: post_script_tasks - trig_incorporate
    D010000: trigproc_run_deferred
    Errors were encountered while processing:
    networkoptix-metavms-mediaserver

    The DEB package is still missing several dependencies, I should be able to install using `--no-install-recommends`, but I need to add several missing dependencies.

    I used the `dpkg --debug` flag to help track the error:

    RUN apt-get update \
        && apt-get install --yes \
            gdb \
            sudo \
            systemd \
            cifs-utils \
            net-tools \
            libcap2-bin \
            libldap2-dev \
        && dpkg --debug=72200 --install ./vms_server.deb \
        && apt-get clean \
        && apt-get autoremove --purge \
        && rm -rf /var/lib/apt/lists/* \
        && rm -rf ./vms_server.deb

     

    0
    Comment actions Permalink
  • Avatar
    Tagir Gadelshin

    Thanks, Pieter. I've created a bug, our dev team will take a look at it

    internal: VMS-23506

    0
    Comment actions Permalink

Please sign in to leave a comment.