Nx 5.0 Auto-discovery does not recognize USB cameras

Answered

Comments

4 comments

  • Avatar
    Norman - Nx Support

    Hello Daiki Kato,

    Can you tell us which build number of version 5.0 you are using?
    You can find this information by hitting F1 in the desktop client and copy (1) the results or share a screenshot:

    Also, can you share which operating system you are using exactly for the server and the client?

    Thank you!

    0
    Comment actions Permalink
  • Avatar
    Daiki Kato

    Hi Norman-Nx-Support,

    I've tried two versions below. Neither of them recognize the USB camera.

    Nx Witness Client version 5.0.0.35270 (be6f59106ab7).
    Built for windows-x64 with msvc.
    OpenGL version: 4.6.0 - Build 26.20.100.7810.
    OpenGL renderer: Intel(R) UHD Graphics.
    OpenGL vendor: Intel.
    OpenGL max texture size: 16384.
    Server amnimo (192.168.11.11): v5.0.0.35270
    Nx Witness Client version 5.0.0.35745 (3bec50d5e175).
    Built for windows-x64 with msvc.
    OpenGL version: 4.6.0 - Build 26.20.100.7810.
    OpenGL renderer: Intel(R) UHD Graphics.
    OpenGL vendor: Intel.
    OpenGL max texture size: 16384.
    Server amnimo (192.168.11.11): v5.0.0.35745

    Server operating system:
      Ubuntu 18.04.6 LTS
      ARM64

    Client operating system:
      Edition: Windows 10 Enterprise
      Version: 20H2

    0
    Comment actions Permalink
  • Avatar
    Norman - Nx Support

    Hi Daiki Kato,

    Good news. It isn't a bug, but intentional behavior. For some reason, this change wasn´t added to the release notes for 5.0. Hence, the reason I missed it as well.

    The default option of discovering the USB cameras / webcameras was disabled since often people wanted to have auto-discovery enabled, but don't want the USB camera on their system.

    So we made this optional in the Server Settings menu, tab General:

    If you tick the box and hit Apply, the USB cameras will be discovered. Obviously, the autodiscovery option has to be enabled in the System Administration menu, tab General as well.

    0
    Comment actions Permalink
  • Avatar
    Daiki Kato

    Hi Norman-Nx-Support,

    I was able to recognize the USB camera. Thank you for your reply.

    0
    Comment actions Permalink

Post is closed for comments.