Raspberry/Banana Pi • Installation Guide

Follow

Comments

13 comments

  • Avatar
    T. Gruner

    It dosent work in raspberry 3 ?

  • Avatar
    T. Gruner

    OK i reset my ras, and install the folder in rigth way, but i cant start the service

    root@raspberrypi:~# root@raspberrypi:~# sudo /etc/init.d/networkoptix-mediaserver start
    bash: root@raspberrypi:~#: command not found
    root@raspberrypi:~# sudo: /etc/init.d/networkoptix-mediaserver: command not found
    bash: sudo:: command not found
    root@raspberrypi:~#

  • Avatar
    Tim Huskisson

    Same install procedure for a Banana Pi?

  • Avatar
    Ian Cook

    Hi Tony,

    Although i am using Hanwha Wave, I think this applies to all PI users.

    Default storage is onto PI SD card (/opt/hanwha/mediaserver/var/data)

    When adding a USB HDD drive, and within Jessie (with all latest updates and packages) the drive mounts automatically, however cannot see a way to add additional local storage to the PI, only external Network Locations.

    Looked at server config, went into advanced settings, no logical way to add or change the recording locations, specifically using a mounted USB drive. (May be a PI thing perhaps)

    Is there a Conf. file that needs to be edited, or because of the limitations of the PI, will it only allow local recording to SD card only?

    Thanks,

    Ian

    (Hanwha Pre-Sales UK)

  • Avatar
    David Ritchie

    Hi

    I've tried this guide on the most recent Stretch and an old Jessy installation (both clean/fresh) and although the service is/can be started I can never find it on the network or connect to the IP address (same PC can SSH to the Pi).

    Looking at the logs it looks like the service is failing to assign a port. Any ideas?

    Also the command line for version 3.1 above is incomplete. As it stands it extracts the zip to the root and chmod +x has too few parameters.

    Cheers

    Dave

  • Avatar
    David Ritchie

    Hi

    Update, I was using an old B+ by accident, switching the SD-Card to a Pi 2 B and it all started to work.

    Cheers

    Dave

  • Avatar
    Kieran Vella

    Has anyone run just the Client on the a RPI3? Will it run? I just want to spot monitor a few cameras...

  • Avatar
    David Ritchie

    Hey

    Does anyone know how to add a USB Hard Disk location in to the server so it can be used to store recordings on? As Ina above I can get the drive mounted but then there isn't a way to add the mount point in to the server configuration

    Do you know if mounting the drive to /opt/networkoptix/mediaserver/var/data will work? I might just give it a try and see what happens

    Cheers

    Dave

  • Avatar
    Sergey Yuldashev

    Hi Dave,

    It won't work. Version 3.1 has special block for USB drives. It was done since Server tried to record to USB drives automatically. Since they have relatively low limit for read/write cycles it was decided to follow this way.

    Apparently this decision might be considered as questionable by end-users, that is why Nx team decided to bring it back in the recent official patches.

    Feel free to upgrade your device to the specific build:

    Build Number:   17256
    Password:   9fnmap

    Just FYI, USB drive will be available for recording only if its capacity is greater than 10% of the maximum attached drive size.

     

  • Avatar
    David Ritchie

    Hey Sergey

    Thanks for the response. I've now updated the server to that build but still don't see the USB drive as an option or a method that allows me to add it.

    I have it mounted at /media/recordings with exFAT formatting in case that is an issue?

    Cheers

    Dave

  • Avatar
    Alex shinetown

    please amend your download link as its going to a page with Chinese content.

  • Avatar
    Michael Miller

    Would NX/WAVE/DWG run on this board? http://www.banana-pi.org/w2.html 

  • Avatar
    Itamar Kerbel

    After testing on RPI 3 B (not B+) I found NX not to work very well at all.

    It would lag after connecting the second camera.

    Tested on the B+ which worked much much better but did rest itsleft (maybe heat problems) not sure.

    Now I'm testing on Asus Tinker Board with Xubuntu from Elar Systems.

    Works for 1 hour... Not tested too much.

    The cronjob doesn't work so I had to add the init script to run level 5 and added sleep to the init script.

    Not sure why you use cronjob anyway...

    I'll try to connect some cameras and see how it goes.

Please sign in to leave a comment.