Hikvision camera goes offline after upgrade firmware.

Follow

Comments

5 comments

  • Avatar
    Ryan Flagler

    What is not documented here is that you must also check "Enable Hikvision-CGI" right above the "Enable ONVIF" box.

    Additionally, the user you setup for ONVIF must also exist in the Configuration -> Usermanagement list. If it ONLY exists as an ONVIF user, it will not work.

  • Avatar
    Sergey Yuldashev

    Hi Ryan,

    Thank you for the valuable input.
    I've already faced this upgrade consequences on couple of sites in Europe. 
    Actually I had to create a user in "Onvif" table only without adding it to main User Management section.
    Also quoting their release notes:

    User management system in ONVIF is independent from device. Add user types, including Media user, Operator and Administrator, Up to 32 users. The password level of ONVIF user is consistent with device user.

    We're going to get more experience with the issue and update the article when more data is received.

  • Avatar
    Ryan Flagler

    Sergey,

    I have 4 Hikvision cameras with v5.5 firmware. I've been testing connectivity and it's very hard to test as NX Witness (DW Spectrum in my case) seems to "hold on" to previous connections and settings.

    Is there a way to force NX Witness (DW Spectrum in my case) to close and reopen the connection to a specific camera?

  • Avatar
    Sergey Yuldashev

    Ryan,

    In short -- there is when several conditions are met. You need to:

    1. Open System Administration menu(Ctrl+Alt+A)
    2. Disable Autodiscovery at "General" tab
    3. Disable "Allow Server to optimize device settings" at "General" tab
    4. Now server will drop the connection to camera every time you close the video stream(if recording is disabled) and will open it again as soon as you drag camera to the layout

    TL; DR

    When autodiscovery feature is enabled Nx Witness(DW Spectrum) Media Server sends http requests to the camera every several seconds even if camera is not streaming video. Thus server tracks camera state which is very important for the potential failover. And also users always see if the camera is online.

    If it's disabled and cameras are added manually Server won't try to reach cameras without a reason.
    Reasons to establish a connection are: opening the video stream, changing interior settings like WDR or reading/saving PTZ presets.

    We look forward to any feedback you'd like to share with us.

  • Avatar
    Ryan Flagler

    Thanks for the information. I've tried almost every combination of configuring my cameras and the ONLY way they work is if "Enable Hikvision-CGI" is checked and the user configured in the ONVIF user page also exists in the main user list. Here is the info on my cameras.

     

    Model: DS-2CD2385FWD-I

    Firmware: V5.5.0 build 170725

Please sign in to leave a comment.